Экспертная система Delphi.int.ru

Сообщество программистов
Общение, помощь, обмен опытом

Логин:
Пароль:
Регистрация | Забыли пароль?

Delphi.int.ru Expert

Другие разделы портала

Переход к вопросу:

#   

Статистика за сегодня:  


Лучшие эксперты

Подробнее »



Вопрос # 1 836

/ вопрос открыт /

Приветствую, уважаемые эксперты!
Подскажите, почему при динамическом создании экземпляра TADOStoredProc, не смотря на то, что в хранимой процедуре есть 1 параметр, при трассировке ADOStoredProc.Parameters.Count равен 0. Соответственно нет возможности передать параметр. При статическом "кидании" компонента на форму проблем не возникает.

Приложение:
  1. ADOSP.Parameters.Refresh();
  2. ShowMessage(IntToStr(ADOSP.Parameters.Count));
  3. ADOSP.Parameters.ParamValues["@senders"]: = Text;


HotMan Вопрос ожидает решения (принимаются ответы, доступен мини-форум)

Вопрос задал: HotMan (статус: Посетитель)
Вопрос отправлен: 23 августа 2008, 17:02
Состояние вопроса: открыт, ответов: 0.


Мини-форум вопроса

Всего сообщений: 2; последнее сообщение — 24 августа 2008, 00:59; участников в обсуждении: 2.
HotMan

HotMan (статус: Посетитель), 23 августа 2008, 17:05 [#1]:

при создании экземпляра были указаны только строка подключения и имя хранимой процедуры
Вадим К

Вадим К (статус: Академик), 24 августа 2008, 00:59 [#2]:

На сколько мне известно, то при ручном создании компонент ничего не знает о хранимой процедуре на сервере и соответсвенно не может узнать параметры. По этому, их надо добавить ручками.
где то так
ADOStoredProc1.Parameters.CreateParameter('paramname',ftString,pdInput, 10,'text')
Галочка "подтверждения прочтения" - вселенское зло.

Чтобы оставлять сообщения в мини-форумах, Вы должны авторизироваться на сайте.

Версия движка: 2.6+ (26.01.2011)
Текущее время: 23 июня 2017, 08:04
Выполнено за 0.03 сек.
Рейтинг@Mail.ru